On 5/6/24 8:15 PM, Philo Lu wrote:
What do you think if I replace "struct __sk_buff" with "void"? The diffs are
appended below.
Because we are not to read anything in these cases, I think using void* is
enough to avoid confusion. On the other hand, to use "struct sk_buff" here, we
have to introduce the definition, and tune codes as the input type of
The sk_buff definition is in vmlinux.h. However, the dynptr_fail.c does not use
vmlinux.h now, so it may need some more changes.
Yep, I think "void *skb" here is fine.
bpf_dynptr_from_skb() is defined as struct __sk_buff in "bpf_kfuncs.h".