Hi, On Thursday, February 29, 2024 8:29:07 PM IST Quentin Monnet wrote: > [...] > Perhaps it would be clearer to split the logics of mount_bpffs_for_pin() > into two subfunctions, one for directories, one for file paths. This way > we would avoid to call malloc() and dirname() when "name" is already a > directory, and it would be easier to follow the different cases. > I was working on these changes here, and I have got a question. In the description of the github issue [1], one scenario is when the given directory does not exist but its parent directory is bpffs. In this scenario no mounting should be done. But to check whether the parent dir is bpffs, the malloc and dirname will still have to be done. In the file subfunction too, the malloc and dirname will have to be done if the given file does not already exist. If my understanding above is right, should the mount_bpffs_for_pin() function still be split? Assuming that the function is split into two subfunctions, there's another question that I have got. > if (is_dir && is_bpffs(name)) > return err; The above condition was added in commit 2a36c26fe3b8 (patch submission [2]). If the function is to be split into two subfunctions for dirs and files, is it ok to remove the above function entirely in the file subfunction? If "is_bpffs(name)" returns false, then that could imply that the file exists and its parent dir is not bpffs, or that the file does not exist and no comment can be made on the parent dir. In either case the malloc and dirname will have to be done. On the other hand if the file exists and is part of the bpffs then this condition will allow the function to exit immediately without doing a malloc and dirname. But this can be determined without the condition as well, since the file being part of the bpffs implies that the dir will be bpffs. Thanks, Sahil [1] https://github.com/libbpf/bpftool/issues/100 [2] https://lore.kernel.org/bpf/1683197138-1894-1-git-send-email-yangpc@xxxxxxxxxx/