On 11/21/19 1:14 PM, Brian Vazquez wrote: > Thanks for reviewing it! > > On Thu, Nov 21, 2019 at 10:43 AM Yonghong Song <yhs@xxxxxx> wrote: >> >> >> >> On 11/19/19 11:30 AM, Brian Vazquez wrote: >>> Tested bpf_map_lookup_batch() and bpf_map_update_batch() >>> functionality. >>> >>> $ ./test_maps >>> ... >>> test_map_lookup_and_delete_batch_array:PASS >>> ... >> >> The test is for lookup_batch() and update_batch() >> and the test name and func name is lookup_and_delete_batch(), >> probably rename is to lookup_and_update_batch_array()? >> > Yes, you are right, I will change the name for next version. > >> It would be good if generic lookup_and_delete_batch() >> and delete_patch() can be tested as well. >> Maybe tried to use prog_array? > > I did test generic_lookup_and_delete_batch with hmap and it worked > fine because I didn't have concurrent deletions. > But yes I will add tests for generic delete and lookup_and_delete, > maybe for the trie map (prog_array doesn't support lookup ang hence > lookup_and_delete won't apply there)? trie_map is a good choice. Basically any map which can be used to test this API.