On 2024-02-14 17:13:03 [+0100], Toke Høiland-Jørgensen wrote: > > diff --git a/net/core/dev.c b/net/core/dev.c > > index de362d5f26559..c3f7d2a6b6134 100644 > > --- a/net/core/dev.c > > +++ b/net/core/dev.c > > @@ -4044,12 +4048,16 @@ static __always_inline struct sk_buff * > > sch_handle_egress(struct sk_buff *skb, int *ret, struct net_device *dev) > > { > > struct bpf_mprog_entry *entry = rcu_dereference_bh(dev->tcx_egress); > > + struct bpf_xdp_storage *xdp_store __free(xdp_storage_clear) = NULL; > > enum skb_drop_reason drop_reason = SKB_DROP_REASON_TC_EGRESS; > > + struct bpf_xdp_storage __xdp_store; > > int sch_ret; > > > > if (!entry) > > return skb; > > > > + xdp_store = xdp_storage_set(&__xdp_store); > > + > > /* qdisc_skb_cb(skb)->pkt_len & tcx_set_ingress() was > > * already set by the caller. > > */ > > > These, and the LWT code, don't actually have anything to do with XDP, > which indicates that the 'xdp_storage' name misleading. Maybe > 'bpf_net_context' or something along those lines? Or maybe we could just > move the flush lists into bpf_redirect_info itself and just keep that as > the top-level name? I'm going to rename it for now as suggested for now. If it is a better fit to include the lists into bpf_redirect_info then I will update accordingly. > -Toke Sebastian