From: Christoph Hellwig <hch@xxxxxx> Date: Tue, 13 Feb 2024 06:57:07 +0100 >> +void __dma_sync_single_for_cpu(struct device *dev, dma_addr_t addr, >> + size_t size, enum dma_data_direction dir); >> +void __dma_sync_single_for_device(struct device *dev, dma_addr_t addr, >> + size_t size, enum dma_data_direction dir); >> +void __dma_sync_sg_for_cpu(struct device *dev, struct scatterlist *sg, >> + int nelems, enum dma_data_direction dir); >> +void __dma_sync_sg_for_device(struct device *dev, struct scatterlist *sg, >> + int nelems, enum dma_data_direction dir); > > Please stick to the two-tab indentation for continuing prototypes. > The version here is not only much harder to read, but also keeps blowing > up the diffs for current and future changes. Oh okay, I didn't know this is the preferred way (differs from the common one used in the kernel, e.g. in the networking code). > > Otherwise this looks good to me. Thanks, Olek