On Fri, 2023-12-01 at 13:51 -0700, Daniel Xu wrote: > On Fri, Dec 01, 2023 at 01:23:14PM -0700, Daniel Xu via Devel wrote: > > === Motivation === > > > > Similar to reading from CO-RE bitfields, we need a CO-RE aware bitfield > > writing wrapper to make the verifier happy. > > > > Two alternatives to this approach are: > > > > 1. Use the upcoming `preserve_static_offset` [0] attribute to disable > > CO-RE on specific structs. > > 2. Use broader byte-sized writes to write to bitfields. > > > > (1) is a bit hard to use. It requires specific and not-very-obvious > > annotations to bpftool generated vmlinux.h. It's also not generally > > available in released LLVM versions yet. > > > > (2) makes the code quite hard to read and write. And especially if > > BPF_CORE_READ_BITFIELD() is already being used, it makes more sense to > > to have an inverse helper for writing. > > > > === Implementation details === > > > > Since the logic is a bit non-obvious, I thought it would be helpful > > to explain exactly what's going on. > > > > To start, it helps by explaining what LSHIFT_U64 (lshift) and RSHIFT_U64 > > (rshift) is designed to mean. Consider the core of the > > BPF_CORE_READ_BITFIELD() algorithm: > > > > val <<= __CORE_RELO(s, field, LSHIFT_U64); > > val = val >> __CORE_RELO(s, field, RSHIFT_U64); > > > > Basically what happens is we lshift to clear the non-relevant (blank) > > higher order bits. Then we rshift to bring the relevant bits (bitfield) > > down to LSB position (while also clearing blank lower order bits). To > > illustrate: > > > > Start: ........XXX...... > > Lshift: XXX......00000000 > > Rshift: 00000000000000XXX > > > > where `.` means blank bit, `0` means 0 bit, and `X` means bitfield bit. > > > > After the two operations, the bitfield is ready to be interpreted as a > > regular integer. > > > > Next, we want to build an alternative (but more helpful) mental model > > on lshift and rshift. That is, to consider: > > > > * rshift as the total number of blank bits in the u64 > > * lshift as number of blank bits left of the bitfield in the u64 > > > > Take a moment to consider why that is true by consulting the above > > diagram. > > > > With this insight, we can how define the following relationship: > > > > bitfield > > _ > > | | > > 0.....00XXX0...00 > > | | | | > > |______| | | > > lshift | | > > |____| > > (rshift - lshift) > > > > That is, we know the number of higher order blank bits is just lshift. > > And the number of lower order blank bits is (rshift - lshift). > > > > Finally, we can examine the core of the write side algorithm: > > > > mask = (~0ULL << rshift) >> lshift; // 1 > > nval = new_val; // 2 > > nval = (nval << rpad) & mask; // 3 > > val = (val & ~mask) | nval; // 4 > > > > (1): Compute a mask where the set bits are the bitfield bits. The first > > left shift zeros out exactly the number of blank bits, leaving a > > bitfield sized set of 1s. The subsequent right shift inserts the > > correct amount of higher order blank bits. > > (2): Place the new value into a word sized container, nval. > > (3): Place nval at the correct bit position and mask out blank bits. > > (4): Mix the bitfield in with original surrounding blank bits. > > > > [0]: https://reviews.llvm.org/D133361 > > Co-authored-by: Eduard Zingerman <eddyz87@xxxxxxxxx> > > Signed-off-by: Eduard Zingerman <eddyz87@xxxxxxxxx> > > Just pointing out I inserted Eduard's tags here. Eduard - I hope that's > OK. Not sure what the usual procedure for this is. Not that I did a big contribution, you and Andrii figured out a much better (and correct) expression :) I'm fine with and without this tag, thank you for working on this.