On Tue, Oct 22, 2019 at 10:21:00AM -0700, Andrii Nakryiko wrote: > LIBBPF_OPTS is implemented as a mix of field declaration and memset > + assignment. This makes it neither variable declaration nor purely > statements, which is a problem, because you can't mix it with either > other variable declarations nor other function statements, because C90 > compiler mode emits warning on mixing all that together. > > This patch changes LIBBPF_OPTS into a strictly declaration of variable > and solves this problem, as can be seen in case of bpftool, which > previously would emit compiler warning, if done this way (LIBBPF_OPTS as > part of function variables declaration block). > > This patch also renames LIBBPF_OPTS into DECLARE_LIBBPF_OPTS to follow > kernel convention for similar macros more closely. > > v1->v2: > - rename LIBBPF_OPTS into DECLARE_LIBBPF_OPTS (Jakub Sitnicki). > > Signed-off-by: Andrii Nakryiko <andriin@xxxxxx> Applied, thanks!