On Mon, Oct 7, 2019 at 10:21 AM Daniel T. Lee <danieltimlee@xxxxxxxxx> wrote: > > Currently, at xdp_adjust_tail_kern.c, MAX_PCKT_SIZE is limited > to 600. To make this size flexible, static global variable > 'max_pcktsz' is added. > > By updating new packet size from the user space, xdp_adjust_tail_kern.o > will use this value as a new max packet size. > > This static global variable can be accesible from .data section with > bpf_object__find_map* from user space, since it is considered as > internal map (accessible with .bss/.data/.rodata suffix). > > If no '-P <MAX_PCKT_SIZE>' option is used, the size of maximum packet > will be 600 as a default. > > For clarity, change the helper to fetch map from 'bpf_map__next' > to 'bpf_object__find_map_fd_by_name'. Also, changed the way to > test prog_fd, map_fd from '!= 0' to '< 0', since fd could be 0 > when stdin is closed. > > Signed-off-by: Daniel T. Lee <danieltimlee@xxxxxxxxx> > > --- > Changes in v6: > - Remove redundant error message Applied. Please keep Acks if you're only doing minor tweaks between versions.