On 07/04/2019 01:11 AM, Saeed Mahameed wrote: > On Wed, Jul 3, 2019 at 3:47 PM Daniel Borkmann <daniel@xxxxxxxxxxxxx> wrote: >> >> Hi David, >> >> The following pull-request contains BPF updates for your *net-next* tree. >> >> There is a minor merge conflict in mlx5 due to 8960b38932be ("linux/dim: >> Rename externally used net_dim members") which has been pulled into your >> tree in the meantime, but resolution seems not that bad ... getting current >> bpf-next out now before there's coming more on mlx5. ;) I'm Cc'ing Saeed >> just so he's aware of the resolution below: >> >> ** First conflict in drivers/net/ethernet/mellanox/mlx5/core/en_main.c: >> >> <<<<<<< HEAD >> static int mlx5e_open_cq(struct mlx5e_channel *c, >> struct dim_cq_moder moder, >> struct mlx5e_cq_param *param, >> struct mlx5e_cq *cq) >> ======= >> int mlx5e_open_cq(struct mlx5e_channel *c, struct net_dim_cq_moder moder, >> struct mlx5e_cq_param *param, struct mlx5e_cq *cq) >> >>>>>>> e5a3e259ef239f443951d401db10db7d426c9497 >> >> Resolution is to take the second chunk and rename net_dim_cq_moder into >> dim_cq_moder. Also the signature for mlx5e_open_cq() in ... >> >> drivers/net/ethernet/mellanox/mlx5/core/en.h +977 >> >> ... and in mlx5e_open_xsk() ... >> >> drivers/net/ethernet/mellanox/mlx5/core/en/xsk/setup.c +64 >> >> ... needs the same rename from net_dim_cq_moder into dim_cq_moder. >> >> ** Second conflict in drivers/net/ethernet/mellanox/mlx5/core/en_main.c: >> >> <<<<<<< HEAD >> int cpu = cpumask_first(mlx5_comp_irq_get_affinity_mask(priv->mdev, ix)); >> struct dim_cq_moder icocq_moder = {0, 0}; >> struct net_device *netdev = priv->netdev; >> struct mlx5e_channel *c; >> unsigned int irq; >> ======= >> struct net_dim_cq_moder icocq_moder = {0, 0}; >> >>>>>>> e5a3e259ef239f443951d401db10db7d426c9497 >> >> Take the second chunk and rename net_dim_cq_moder into dim_cq_moder >> as well. >> > > Thank you Daniel, Looks Good, > I didn't test this since i am traveling, will double check tomorrow. > but basically all you need is to pass the build. That was definitely the case for me, thanks!