On Wed, 27 Feb 2019 15:47:56 -0800, Andrii Nakryiko wrote: > On Wed, Feb 27, 2019 at 3:31 PM Jakub Kicinski > <jakub.kicinski@xxxxxxxxxxxxx> wrote: > > > > For historical reasons the helper to loop over maps in an object > > is called bpf_map__for_each while it really should be called > > bpf_object__for_each_map. Rename and add a correctly named > > define for backward compatibility. > > Seems like there are at least 3 more functions that are not named correctly: > - __bpf_map__iter (__bpf_object__iter_map?) > - bpf_map__next (=> bpf_object__next_map?) > - bpf_map__prev (=> bpf_object__prev_map?) > > Let's rename them as well? At least those are consistently named between programs and maps. I'm happy to do the rename if we don't need backward compat, seems a little much to add aliases? > > Switch all in-tree users to the correct name (Quentin). > > > > Signed-off-by: Jakub Kicinski <jakub.kicinski@xxxxxxxxxxxxx> > > Reviewed-by: Quentin Monnet <quentin.monnet@xxxxxxxxxxxxx> > > diff --git a/tools/lib/bpf/libbpf.h b/tools/lib/bpf/libbpf.h > > index 6c0168f8bba5..b4652aa1a58a 100644 > > --- a/tools/lib/bpf/libbpf.h > > +++ b/tools/lib/bpf/libbpf.h > > @@ -278,10 +278,11 @@ bpf_object__find_map_by_offset(struct bpf_object *obj, size_t offset); > > > > LIBBPF_API struct bpf_map * > > bpf_map__next(struct bpf_map *map, struct bpf_object *obj); > > -#define bpf_map__for_each(pos, obj) \ > > +#define bpf_object__for_each_map(pos, obj) \ > > for ((pos) = bpf_map__next(NULL, (obj)); \ > > (pos) != NULL; \ > > (pos) = bpf_map__next((pos), (obj))) > > +#define bpf_map__for_each bpf_object__for_each_map > > Should we get rid of this as well, instead of accumulating cruft? Well, we did some gymnastics in the past to maintain backward compat, I thought we do need it..?