[PATCH 10/30] header: Rename kfree_sensitive(x) to kzfree(x)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This was added in upstream Linux commit 453431a54934 ("mm, treewide:
rename kzfree() to kfree_sensitive()").

Signed-off-by: Hauke Mehrtens <hauke@xxxxxxxxxx>
---
 backport/backport-include/linux/slab.h | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/backport/backport-include/linux/slab.h b/backport/backport-include/linux/slab.h
index 66f0cc0d..f36dc40a 100644
--- a/backport/backport-include/linux/slab.h
+++ b/backport/backport-include/linux/slab.h
@@ -24,4 +24,8 @@ static inline void *kmalloc_array(size_t n, size_t size, gfp_t flags)
 }
 #endif
 
+#if LINUX_VERSION_IS_LESS(5,9,0)
+#define kfree_sensitive(x)	kzfree(x)
+#endif
+
 #endif /* __BACKPORT_SLAB_H */
-- 
2.20.1

--
To unsubscribe from this list: send the line "unsubscribe backports" in



[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [ECOS]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux