[Public] Series is Reviewed-by: Lijo Lazar <lijo.lazar@xxxxxxx> -----Original Message----- From: Powell, Darren <Darren.Powell@xxxxxxx> Sent: Sunday, June 6, 2021 10:30 AM To: amd-gfx@xxxxxxxxxxxxxxxxxxxxx Cc: Powell, Darren <Darren.Powell@xxxxxxx> Subject: [PATCH v3 0/6] Modify smu_get_power_limit to implement Powerplay API === Description === modify smu_get_power_limit to implement Powerplay API v3: renamed enum pp_power_sample_window to enum pp_power_limit v2: rewrote the patchset to use two enums as args to get_power === Test System === * DESKTOP(AMD FX-8350 + NAVI10(731F/ca), BIOS: F2) + ISO(Ubuntu 20.04.1 LTS) + Kernel(5.11.0-custom-fdoagd5f) === Patch Summary === linux: (git@xxxxxxxxxxxxxxxxxxxxxx:agd5f) origin/amd-staging-drm-next @ 3ac16cf10525 + 1a7ee0a2bc79 amdgpu/pm: reorder definition of swsmu_pm_funcs for readability + 3d0481caced7 amdgpu/pm: clean up smu_get_power_limit function signature + 593d896cf90c amdgpu/pm: modify Powerplay API get_power_limit to use new pp_power enums + 45339b7190fc amdgpu/pm: modify and add smu_get_power_limit to Powerplay API + 8f4be6d2a9df amdgpu/pm: handle return value for get_power_limit + a2e5f8ecd04f amdgpu/pm: add kernel documentation for smu_get_power_limit === Tests === ==== get_power_limit Test ==== * Test AMDGPU_PCI_ADDR=`lspci -nn | grep "VGA\|Display" | cut -d " " -f 1` AMDGPU_HWMON=`ls -la /sys/class/hwmon | grep $AMDGPU_PCI_ADDR | cut -d " " -f 11` HWMON_DIR=/sys/class/hwmon/${AMDGPU_HWMON} lspci -nn | grep "VGA\|Display" ; \ echo "=== power1 cap ===" ; cat $HWMON_DIR/power1_cap ; \ echo "=== power1 cap max ===" ; cat $HWMON_DIR/power1_cap_max ; \ echo "=== power1 cap def ===" ; cat $HWMON_DIR/power1_cap_default ==== Documentation Test ==== * Insert temp documentation ** Documentation/gpu/amdgpu.rst vi Documentation/gpu/amdgpu.rst ** added text to start ------------START------------ Documentation Testing ===================== Power Limit ----------- .. kernel-doc:: drivers/gpu/drm/amd/include/kgd_pp_interface.h :doc: amdgpu_pp_power .. kernel-doc:: drivers/gpu/drm/amd/include/kgd_pp_interface.h :identifiers: pp_power_limit_level .. kernel-doc:: drivers/gpu/drm/amd/include/kgd_pp_interface.h :identifiers: pp_power_type .. kernel-doc:: drivers/gpu/drm/amd/pm/swsmu/amdgpu_smu.c :identifiers: smu_get_power_limit -------------END------------- * Setup cd ~/workspace/linux . sphinx_2.4.4/bin/activate * Build export SPHINXDOCLOG=sphinx.build.log cp $SPHINXDOCLOG{,.old} time make -j 8 htmldocs |& tee $SPHINXDOCLOG * View firefox file:///home/dapowell/workspace/linux/Documentation/output/gpu/amdgpu.html Darren Powell (6): amdgpu/pm: reorder definition of swsmu_pm_funcs for readability amdgpu/pm: clean up smu_get_power_limit function signature amdgpu/pm: modify Powerplay API get_power_limit to use new pp_power enums amdgpu/pm: modify and add smu_get_power_limit to Powerplay API amdgpu/pm: handle return value for get_power_limit amdgpu/pm: add kernel documentation for smu_get_power_limit .../gpu/drm/amd/include/kgd_pp_interface.h | 47 ++++++++- drivers/gpu/drm/amd/pm/amdgpu_pm.c | 64 +++++++------ drivers/gpu/drm/amd/pm/inc/amdgpu_smu.h | 5 +- .../gpu/drm/amd/pm/powerplay/amd_powerplay.c | 33 ++++--- drivers/gpu/drm/amd/pm/swsmu/amdgpu_smu.c | 96 +++++++++++++------ 5 files changed, 172 insertions(+), 73 deletions(-) base-commit: f60839821f77d6db48bfc986e0391b70b31fede8 -- 2.31.1 _______________________________________________ amd-gfx mailing list amd-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/amd-gfx