Re: [PATCH 3/3] drm/amdgpu: disable VCN for navi10 blockchain SKU

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 2020-10-21 03:56, Tianci Yin wrote:
> From: "Tianci.Yin" <tianci.yin@xxxxxxx>
> 
> The blockchain SKU has no VCN support, remove it.
> 
> Change-Id: I26fbdabdf67aada24c5aebef999ee8b5f9c0bfe2
> Signed-off-by: Tianci.Yin <tianci.yin@xxxxxxx>
> ---
>  drivers/gpu/drm/amd/amdgpu/nv.c | 5 ++++-
>  1 file changed, 4 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/gpu/drm/amd/amdgpu/nv.c b/drivers/gpu/drm/amd/amdgpu/nv.c
> index ce787489aaeb..ffe4c2b3ea5f 100644
> --- a/drivers/gpu/drm/amd/amdgpu/nv.c
> +++ b/drivers/gpu/drm/amd/amdgpu/nv.c
> @@ -538,7 +538,10 @@ int nv_set_ip_blocks(struct amdgpu_device *adev)
>  		if (adev->firmware.load_type == AMDGPU_FW_LOAD_DIRECT &&
>  		    !amdgpu_sriov_vf(adev))
>  			amdgpu_device_ip_block_add(adev, &smu_v11_0_ip_block);
> -		amdgpu_device_ip_block_add(adev, &vcn_v2_0_ip_block);
> +		if (adev->pdev->device != 0x731E ||
> +		    (adev->pdev->revision != 0xC6 &&
> +		     adev->pdev->revision != 0xC7))
> +			amdgpu_device_ip_block_add(adev, &vcn_v2_0_ip_block);

It would be much easier to read and understand this conditional,
if you'd copy the conditional you have in patch 2, and add
an inversion to the front:

		if (!(device is block-chain SKU))
			add IP block header vcn2;

And you'd maintain similarity to an already introduced conditional,
for instance of someone is doing a search through the code.

Regards,
Luben

>  		amdgpu_device_ip_block_add(adev, &jpeg_v2_0_ip_block);
>  		if (adev->enable_mes)
>  			amdgpu_device_ip_block_add(adev, &mes_v10_1_ip_block);
> 

_______________________________________________
amd-gfx mailing list
amd-gfx@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/amd-gfx



[Index of Archives]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux