Re: [PATCH] drm/amdgpu: Remove an unnecessary condition check in reserve_bo_and_cond_vms()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



> There is no need to if check again,

Thanks for this information.

* Should the function name be mentioned in this change description?

* Would you like to adjust the patch subject?


> maybe we could merge into the above else branch.

I suggest to reconsider this wording.


…
> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gpuvm.c
> @@ -735,10 +735,8 @@ static int reserve_bo_and_cond_vms(struct kgd_mem *mem,
…

I propose to take further coding style aspects into account.
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/coding-style.rst?id=90280eaa88ac1a9140dc759941123530d5545bb6#n191

Possible refactoring:
	if (ret) {
		pr_err(…);
		…
	} else {
		ctx->reserved = true;
	}


How do you think about to add the tag “Fixes”?

Regards,
Markus
_______________________________________________
amd-gfx mailing list
amd-gfx@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/amd-gfx




[Index of Archives]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux