From: Bjorn Helgaas <bhelgaas@xxxxxxxxxx> Use pcie_capability_read_word() and similar instead of using pci_read_config_word() directly. Add #defines to replace some magic numbers. Fix typos in use of Transmit Margin field. These are currently on my pci/misc branch for v5.5. Let me know if you see any issues. Bjorn Helgaas (5): PCI: Add #defines for Enter Compliance, Transmit Margin drm/amdgpu: Correct Transmit Margin masks drm/amdgpu: Replace numbers with PCI_EXP_LNKCTL2 definitions drm/radeon: Correct Transmit Margin masks drm/radeon: Replace numbers with PCI_EXP_LNKCTL2 definitions Frederick Lawler (2): drm/amdgpu: Prefer pcie_capability_read_word() drm/radeon: Prefer pcie_capability_read_word() drivers/gpu/drm/amd/amdgpu/cik.c | 95 +++++++++++++++++++------------ drivers/gpu/drm/amd/amdgpu/si.c | 97 ++++++++++++++++++++------------ drivers/gpu/drm/radeon/cik.c | 94 +++++++++++++++++++------------ drivers/gpu/drm/radeon/si.c | 97 ++++++++++++++++++++------------ include/uapi/linux/pci_regs.h | 2 + 5 files changed, 243 insertions(+), 142 deletions(-) -- 2.24.0.432.g9d3f5f5b63-goog _______________________________________________ amd-gfx mailing list amd-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/amd-gfx