Re: [PATCH] drm/amdkfd: Rename kfd_kernel_queue_*.c to kfd_packet_manager_*.c

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 2019-11-13 5:26 p.m., Yong Zhao wrote:
Oh, I did not realize the part inside of the file. I think v9->ai is better, because the packet format header uses ai. Also v9 will give people an impression of gfx9.

There are a lot of other places in KFD that use the "v9" suffix. Like I said, if we decide to change this, it will affect lots of other KFD files and functions.

The code in the packet manager deals with the MEC, which is part of the GFX engine. So referring to the GFX version (v9) makes sense. AI refers to the whole SOC generation by its deprecated code name that the Vega code name for the SOC that's used elsewhere in the code.

Regards,
  Felix


Yong

On 2019-11-13 5:19 p.m., Felix Kuehling wrote:
On 2019-11-13 5:09 p.m., Yong Zhao wrote:
After the recent cleanup, the functionalities provided by the previous
kfd_kernel_queue_*.c are actually all packet manager related. So rename
them to reflect that.

Change-Id: I6544ccb38da827c747544c0787aa949df20edbb0
Signed-off-by: Yong Zhao <Yong.Zhao@xxxxxxx>
---
  drivers/gpu/drm/amd/amdkfd/Makefile | 4 ++--
  .../amdkfd/{kfd_kernel_queue_v9.c => kfd_packet_manager_ai.c} | 0
  .../amdkfd/{kfd_kernel_queue_vi.c => kfd_packet_manager_vi.c} | 0
  3 files changed, 2 insertions(+), 2 deletions(-)
  rename drivers/gpu/drm/amd/amdkfd/{kfd_kernel_queue_v9.c => kfd_packet_manager_ai.c} (100%)   rename drivers/gpu/drm/amd/amdkfd/{kfd_kernel_queue_vi.c => kfd_packet_manager_vi.c} (100%)

diff --git a/drivers/gpu/drm/amd/amdkfd/Makefile b/drivers/gpu/drm/amd/amdkfd/Makefile
index f93a16372325..55bfecf04239 100644
--- a/drivers/gpu/drm/amd/amdkfd/Makefile
+++ b/drivers/gpu/drm/amd/amdkfd/Makefile
@@ -38,9 +38,9 @@ AMDKFD_FILES    := $(AMDKFD_PATH)/kfd_module.o \
          $(AMDKFD_PATH)/kfd_mqd_manager_v9.o \
          $(AMDKFD_PATH)/kfd_mqd_manager_v10.o \
          $(AMDKFD_PATH)/kfd_kernel_queue.o \
-        $(AMDKFD_PATH)/kfd_kernel_queue_vi.o \
-        $(AMDKFD_PATH)/kfd_kernel_queue_v9.o \
          $(AMDKFD_PATH)/kfd_packet_manager.o \
+        $(AMDKFD_PATH)/kfd_packet_manager_vi.o \
+        $(AMDKFD_PATH)/kfd_packet_manager_ai.o \

This naming convention is inconsistent with the rest of KFD. We use _v9, not _ai. Also the function s inside this file are named _v9. If we decide to change that naming convention, it should not be accidental and piece-meal. It should be deliberate and comprehensive.

Regards,
  Felix


$(AMDKFD_PATH)/kfd_process_queue_manager.o \
          $(AMDKFD_PATH)/kfd_device_queue_manager.o \
          $(AMDKFD_PATH)/kfd_device_queue_manager_cik.o \
diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_kernel_queue_v9.c b/drivers/gpu/drm/amd/amdkfd/kfd_packet_manager_ai.c
similarity index 100%
rename from drivers/gpu/drm/amd/amdkfd/kfd_kernel_queue_v9.c
rename to drivers/gpu/drm/amd/amdkfd/kfd_packet_manager_ai.c
diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_kernel_queue_vi.c b/drivers/gpu/drm/amd/amdkfd/kfd_packet_manager_vi.c
similarity index 100%
rename from drivers/gpu/drm/amd/amdkfd/kfd_kernel_queue_vi.c
rename to drivers/gpu/drm/amd/amdkfd/kfd_packet_manager_vi.c
_______________________________________________
amd-gfx mailing list
amd-gfx@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/amd-gfx




[Index of Archives]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux