Re: [PATCH] drm/amd/amdgpu: cast mem->num_pages to 64-bits when shifting

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Am 17.06.19 um 21:15 schrieb Kuehling, Felix:
Looks good to me. One cosmetic comment inline. With that fixed this
patch is Reviewed-by:  Felix Kuehling <Felix.Kuehling@xxxxxxx>

On 2019-06-14 12:51 p.m., StDenis, Tom wrote:
On 32-bit hosts mem->num_pages is 32-bits and can overflow
when shifted.  Add a cast to avoid this.

Signed-off-by: Tom St Denis <tom.stdenis@xxxxxxx>
---
   drivers/gpu/drm/amd/amdgpu/amdgpu_vram_mgr.c | 8 +++++---
   1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_vram_mgr.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_vram_mgr.c
index c963ad86072e..31895d3c33de 100644
--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_vram_mgr.c
+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_vram_mgr.c
@@ -279,14 +279,16 @@ static int amdgpu_vram_mgr_new(struct ttm_mem_type_manager *man,
   	uint64_t vis_usage = 0;
   	unsigned i;
   	int r;
+	uint64_t mem_bytes;
Christian likes the "upside-down christmas tree" to help readability of
local variable declarations.

Ah, yeah. Thanks for the note.

I actually don't care about that much, but I always get rejects from upstream subsystem maintainers if I don't do this.

It's most likely not even documented somewhere,
Christian.



lpfn = place->lpfn;
   	if (!lpfn)
   		lpfn = man->size;
/* bail out quickly if there's likely not enough VRAM for this BO */
-	if (atomic64_add_return(mem->num_pages << PAGE_SHIFT, &mgr->usage) > adev->gmc.mc_vram_size) {
-		atomic64_sub(mem->num_pages << PAGE_SHIFT, &mgr->usage);
+	mem_bytes = (u64)mem->num_pages << PAGE_SHIFT;
+	if (atomic64_add_return(mem_bytes, &mgr->usage) > adev->gmc.mc_vram_size) {
+		atomic64_sub(mem_bytes, &mgr->usage);
   		mem->mm_node = NULL;
   		return 0;
   	}
@@ -308,7 +310,7 @@ static int amdgpu_vram_mgr_new(struct ttm_mem_type_manager *man,
   	nodes = kvmalloc_array((uint32_t)num_nodes, sizeof(*nodes),
   			       GFP_KERNEL | __GFP_ZERO);
   	if (!nodes) {
-		atomic64_sub(mem->num_pages << PAGE_SHIFT, &mgr->usage);
+		atomic64_sub(mem_bytes, &mgr->usage);
   		return -ENOMEM;
   	}
_______________________________________________
amd-gfx mailing list
amd-gfx@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/amd-gfx

_______________________________________________
amd-gfx mailing list
amd-gfx@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/amd-gfx




[Index of Archives]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux