________________________________ From: amd-gfx <amd-gfx-bounces@xxxxxxxxxxxxxxxxxxxxx> on behalf of Oded Gabbay <oded.gabbay at gmail.com> Sent: Wednesday, January 31, 2018 10:17 AM To: Kuehling, Felix Cc: amd-gfx list Subject: Re: [PATCH 7/9] drm/amdkfd: Add dGPU support to kernel_queue_init On Fri, Jan 5, 2018 at 12:17 AM, Felix Kuehling <Felix.Kuehling at amd.com> wrote: > Recognize dGPU ASIC families. > > Signed-off-by: Felix Kuehling <Felix.Kuehling at amd.com> > --- > drivers/gpu/drm/amd/amdkfd/kfd_kernel_queue.c | 5 +++++ > 1 file changed, 5 insertions(+) > > diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_kernel_queue.c b/drivers/gpu/drm/amd/amdkfd/kfd_kernel_queue.c > index 5dc6567..69f4964 100644 > --- a/drivers/gpu/drm/amd/amdkfd/kfd_kernel_queue.c > +++ b/drivers/gpu/drm/amd/amdkfd/kfd_kernel_queue.c > @@ -297,10 +297,15 @@ struct kernel_queue *kernel_queue_init(struct kfd_dev *dev, > > switch (dev->device_info->asic_family) { > case CHIP_CARRIZO: > + case CHIP_TONGA: > + case CHIP_FIJI: > + case CHIP_POLARIS10: > + case CHIP_POLARIS11: I believe POLARIS is from arcatic islands, no ? Maybe rename kernel_queue_init_vi to kernel_queue_init_vi_ai ? or create a new function kernel_queue_init_ai() and assign same functions as vi ? Either way, I think you need to address that. They are all gfx8. adding ai just confuses things. Alex > kernel_queue_init_vi(&kq->ops_asic_specific); > break; > > case CHIP_KAVERI: > + case CHIP_HAWAII: > kernel_queue_init_cik(&kq->ops_asic_specific); > break; > default: > -- > 2.7.4 > Other then that, This patch is: Reviewed-by: Oded Gabbay <oded.gabbay at gmail.com> _______________________________________________ amd-gfx mailing list amd-gfx at lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/amd-gfx -------------- next part -------------- An HTML attachment was scrubbed... URL: <https://lists.freedesktop.org/archives/amd-gfx/attachments/20180131/4a18c48a/attachment-0001.html>