Am 13.11.2017 um 08:16 schrieb Roger He: > keep consistency with threshold of swapout > > Change-Id: I5b14d18ed7a9f79810cc50c023ac9e240bddf101 > Signed-off-by: Roger He <Hongbo.He at amd.com> I still think multiple lines would be easier to read, but if you prefer it like this I'm fine with it as well. Patch is Reviewed-by: Christian König <christian.koenig at amd.com> Regards, Christian. > --- > drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c | 11 ++++++++--- > 1 file changed, 8 insertions(+), 3 deletions(-) > > diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c > index cdbdf67..eb53e96 100644 > --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c > +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c > @@ -1330,9 +1330,14 @@ int amdgpu_ttm_init(struct amdgpu_device *adev) > DRM_INFO("amdgpu: %uM of VRAM memory ready\n", > (unsigned) (adev->mc.real_vram_size / (1024 * 1024))); > > - if (amdgpu_gtt_size == -1) > - gtt_size = max((AMDGPU_DEFAULT_GTT_SIZE_MB << 20), > - adev->mc.mc_vram_size); > + if (amdgpu_gtt_size == -1) { > + struct sysinfo si; > + > + si_meminfo(&si); > + gtt_size = min(max((AMDGPU_DEFAULT_GTT_SIZE_MB << 20), > + adev->mc.mc_vram_size), > + ((uint64_t)si.totalram * si.mem_unit * 3/4)); > + } > else > gtt_size = (uint64_t)amdgpu_gtt_size << 20; > r = ttm_bo_init_mm(&adev->mman.bdev, TTM_PL_TT, gtt_size >> PAGE_SHIFT);