Re: [PATCH 1/8] HID: amd_sfh: rename float_to_int() to amd_sfh_float_to_int()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Fri, 29 Mar 2024, Li Ma wrote:

> From: Basavaraj Natikar <Basavaraj.Natikar@xxxxxxx>
> [Backport]: to fix amd_sfh init fail issue in ASDN
> Current amd_sfh driver has float_to_int() to convert units from
> float to int. This is fine until this function gets called outside of
> the current scope of file.
> Add a prefix "amd_sfh" to float_to_int() so that function represents
> the driver name. This function will be called by multiple callers in the
> next patch.
> Link:
> Reviewed-by: Ilpo Järvinen <ilpo.jarvinen@xxxxxxxxxxxxxxx>
> Co-developed-by: Shyam Sundar S K <Shyam-sundar.S-k@xxxxxxx>
> Signed-off-by: Shyam Sundar S K <Shyam-sundar.S-k@xxxxxxx>
> Signed-off-by: Basavaraj Natikar <Basavaraj.Natikar@xxxxxxx>
> Signed-off-by: Jiri Kosina <jkosina@xxxxxxxx>
> (cherry picked from commit 4e71d262899d7bab1f0c65936a2e639afeb83e4d)

What am I supposed to do with this? All of this code has already been 

Jiri Kosina

[Index of Archives]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux