Am 12.12.2017 um 10:33 schrieb Roger He: > on_alloc_stage: is this operation on allocation stage > resv: reservation bo used of this operation > > Change-Id: I01ea482e8c7470014196eb218e2ff8913306eef0 > Signed-off-by: Roger He <Hongbo.He at amd.com> > --- > include/drm/ttm/ttm_bo_api.h | 4 ++++ > 1 file changed, 4 insertions(+) > > diff --git a/include/drm/ttm/ttm_bo_api.h b/include/drm/ttm/ttm_bo_api.h > index 368eb02..25de597 100644 > --- a/include/drm/ttm/ttm_bo_api.h > +++ b/include/drm/ttm/ttm_bo_api.h > @@ -263,6 +263,8 @@ struct ttm_bo_kmap_obj { > * > * @interruptible: Sleep interruptible if sleeping. > * @no_wait_gpu: Return immediately if the GPU is busy. > + * @on_alloc_stage: is this operation on allocation stage > + * @resv: resvation bo used > * > * Context for TTM operations like changing buffer placement or general memory > * allocation. > @@ -270,6 +272,8 @@ struct ttm_bo_kmap_obj { > struct ttm_operation_ctx { > bool interruptible; > bool no_wait_gpu; > + bool on_alloc_stage; The name describes how amdgpu want to use the flag and not what effect it has. How about "allow_reserved_eviction"? And also please update the documentation with something like: * @allow_reserved_eviction: Allow eviction of reserved BOs. * @resv: Reservation object to allow reserved evictions with. Alternative we could put the ww_mutex context in here as Daniel suggested, but I think we should stick with what we have for now and make that change when we find another use case for this. Christian. > + struct reservation_object *resv; > uint64_t bytes_moved; > }; >