[PATCH] drm/amd/powerplay: Unify family defines

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Am 06.07.2016 um 16:13 schrieb Tom St Denis:
> s/AMD_FAMILY_/AMDGPU_FAMILY_/
>
> Signed-off-by: Tom St Denis <tom.stdenis at amd.com>

Reviewed-by: Christian König <christian.koenig at amd.com>

> ---
>   drivers/gpu/drm/amd/include/amd_shared.h      | 9 ---------
>   drivers/gpu/drm/amd/powerplay/hwmgr/hwmgr.c   | 5 +++--
>   drivers/gpu/drm/amd/powerplay/smumgr/smumgr.c | 5 +++--
>   3 files changed, 6 insertions(+), 13 deletions(-)
>
> diff --git a/drivers/gpu/drm/amd/include/amd_shared.h b/drivers/gpu/drm/amd/include/amd_shared.h
> index afbd8765dc73..a74a0d2ff1ca 100644
> --- a/drivers/gpu/drm/amd/include/amd_shared.h
> +++ b/drivers/gpu/drm/amd/include/amd_shared.h
> @@ -26,15 +26,6 @@
>   #define AMD_MAX_USEC_TIMEOUT		100000  /* 100 ms */
>   
>   /*
> -* Supported GPU families (aligned with amdgpu_drm.h)
> -*/
> -#define AMD_FAMILY_UNKNOWN              0
> -#define AMD_FAMILY_CI                   120 /* Bonaire, Hawaii */
> -#define AMD_FAMILY_KV                   125 /* Kaveri, Kabini, Mullins */
> -#define AMD_FAMILY_VI                   130 /* Iceland, Tonga */
> -#define AMD_FAMILY_CZ                   135 /* Carrizo */
> -
> -/*
>    * Supported ASIC types
>    */
>   enum amd_asic_type {
> diff --git a/drivers/gpu/drm/amd/powerplay/hwmgr/hwmgr.c b/drivers/gpu/drm/amd/powerplay/hwmgr/hwmgr.c
> index 339a9361c5a5..03b6128ebc20 100644
> --- a/drivers/gpu/drm/amd/powerplay/hwmgr/hwmgr.c
> +++ b/drivers/gpu/drm/amd/powerplay/hwmgr/hwmgr.c
> @@ -24,6 +24,7 @@
>   #include <linux/types.h>
>   #include <linux/kernel.h>
>   #include <linux/slab.h>
> +#include <drm/amdgpu_drm.h>
>   #include "cgs_common.h"
>   #include "power_state.h"
>   #include "hwmgr.h"
> @@ -61,10 +62,10 @@ int hwmgr_init(struct amd_pp_init *pp_init, struct pp_instance *handle)
>   	hwmgr->powercontainment_enabled = pp_init->powercontainment_enabled;
>   
>   	switch (hwmgr->chip_family) {
> -	case AMD_FAMILY_CZ:
> +	case AMDGPU_FAMILY_CZ:
>   		cz_hwmgr_init(hwmgr);
>   		break;
> -	case AMD_FAMILY_VI:
> +	case AMDGPU_FAMILY_VI:
>   		switch (hwmgr->chip_id) {
>   		case CHIP_TONGA:
>   			tonga_hwmgr_init(hwmgr);
> diff --git a/drivers/gpu/drm/amd/powerplay/smumgr/smumgr.c b/drivers/gpu/drm/amd/powerplay/smumgr/smumgr.c
> index 0728c1e3d97a..7723473e51a0 100644
> --- a/drivers/gpu/drm/amd/powerplay/smumgr/smumgr.c
> +++ b/drivers/gpu/drm/amd/powerplay/smumgr/smumgr.c
> @@ -23,6 +23,7 @@
>   #include <linux/types.h>
>   #include <linux/kernel.h>
>   #include <linux/slab.h>
> +#include <drm/amdgpu_drm.h>
>   #include "pp_instance.h"
>   #include "smumgr.h"
>   #include "cgs_common.h"
> @@ -52,10 +53,10 @@ int smum_init(struct amd_pp_init *pp_init, struct pp_instance *handle)
>   	handle->smu_mgr = smumgr;
>   
>   	switch (smumgr->chip_family) {
> -	case AMD_FAMILY_CZ:
> +	case AMDGPU_FAMILY_CZ:
>   		cz_smum_init(smumgr);
>   		break;
> -	case AMD_FAMILY_VI:
> +	case AMDGPU_FAMILY_VI:
>   		switch (smumgr->chip_id) {
>   		case CHIP_TONGA:
>   			tonga_smum_init(smumgr);



[Index of Archives]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux