Quoting Kuninori Morimoto (2019-03-06 16:20:40) > > Hi Stephen > > > > index 14cbf23..96053a9 100644 > > > --- a/drivers/clk/clk.c > > > +++ b/drivers/clk/clk.c > > > @@ -4213,7 +4213,7 @@ struct clk *of_clk_get_by_name(struct device_node *np, const char *name) > > > if (!np) > > > return ERR_PTR(-ENOENT); > > > > > > - return __of_clk_get(np, -1, np->full_name, name); > > > + return __of_clk_get(np, 0, np->full_name, name); > > > } > > > > Yes this is correct. Thanks for debugging and fixing my thinko here. I > > was thinking that nobody would call of_clk_get_by_name() unless they > > wanted to find some clk that had a matching name, but it seems that we > > also allow NULL to be passed as the name to mean the typical "wildcard > > match" thing that clkdev has done for years. I'll throw this patch on > > top of the merge commit so the breakage window is small as I'd rather > > not rewrite the series just for this. Thanks. > > Ahh, OK. > So, how about this ? it is including both opinion :) > I'm not sure which one should be applied, but both can solve my issue. > No worries. I applied your original patch. _______________________________________________ Alsa-devel mailing list Alsa-devel@xxxxxxxxxxxxxxxx https://mailman.alsa-project.org/mailman/listinfo/alsa-devel