[PATCH 0/4] ALSA: rawmidi cleanups

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,

this is a patchset mainly as a cleanup of rawmidi code, and most of
them are just coding style or readability fixes without functional
behavior changes.  The last patch replaces kmalloc() with kvmalloc()
for buffer allocations, which may fail frequently as is.


Takashi

===

Takashi Iwai (4):
  ALSA: rawmidi: Tidy up coding styles
  ALSA: rawmidi: Simplify error paths
  ALSA: rawmidi: Minor code refactoring
  ALSA: rawmidi: Use kvmalloc() for buffers

 sound/core/rawmidi.c | 248 ++++++++++++++++++++++---------------------
 1 file changed, 128 insertions(+), 120 deletions(-)

-- 
2.18.0

_______________________________________________
Alsa-devel mailing list
Alsa-devel@xxxxxxxxxxxxxxxx
http://mailman.alsa-project.org/mailman/listinfo/alsa-devel



[Index of Archives]     [ALSA User]     [Linux Audio Users]     [Kernel Archive]     [Asterisk PBX]     [Photo Sharing]     [Linux Sound]     [Video 4 Linux]     [Gimp]     [Yosemite News]

  Powered by Linux