On Fri, Mar 09, 2018 at 10:01:24PM +0530, Charles Keepax wrote: > On Tue, Mar 06, 2018 at 04:30:30PM +0530, Shreyas NC wrote: > > Extend the multi CPU support in DAPM functions to check for > > valid widgets and connected widgets. > > > > Signed-off-by: Shreyas NC <shreyas.nc@xxxxxxxxx> > > --- > > sound/soc/soc-dapm.c | 71 ++++++++++++++++++++++++++++++++++------------------ > > 1 file changed, 46 insertions(+), 25 deletions(-) > > > > diff --git a/sound/soc/soc-dapm.c b/sound/soc/soc-dapm.c > > index 2f34590..6c7b0f4 100644 > > --- a/sound/soc/soc-dapm.c > > +++ b/sound/soc/soc-dapm.c > > @@ -4066,38 +4066,57 @@ int snd_soc_dapm_link_dai_widgets(struct snd_soc_card *card) > > return 0; > > } > > > > -static void dapm_connect_dai_link_widgets(struct snd_soc_card *card, > > - struct snd_soc_pcm_runtime *rtd) > > +static void dapm_check_dai_valid_widget(struct snd_soc_card *card, > > + struct snd_soc_pcm_runtime *rtd, > > + struct snd_soc_dai *codec_dai, > > + struct snd_soc_dai *cpu_dai) > > Not sure about the name here dapm_check_dai_valid_widget doesn't > sound like it should be adding paths, otherwise I think this one > looks ok. > Ok, does dapm_add_valid_widget() sound better? --Shreyas -- _______________________________________________ Alsa-devel mailing list Alsa-devel@xxxxxxxxxxxxxxxx http://mailman.alsa-project.org/mailman/listinfo/alsa-devel