Re: [PATCH 2/3] ASoC: add snd_soc_card_disconnect_sync()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Mark

> > +void snd_soc_card_disconnect_sync(struct device *dev)
> > +{
> > +	struct snd_soc_component *component = snd_soc_lookup_component(dev, NULL);
> > +
> > +	if (!component || !component->card)
> > +		return;
> > +
> > +	snd_card_disconnect_sync(component->card->snd_card);
> 
> Is this the right name for ASoC or should it just be
> snd_soc_disconnect_sync()?  It'll work for any device that's in a card.

Ahh, indeed.
snd_soc_disconnect_sync() is better naming.
I will fix name in v2 (Based on Takashi's branch)

Best regards
---
Kuninori Morimoto
_______________________________________________
Alsa-devel mailing list
Alsa-devel@xxxxxxxxxxxxxxxx
http://mailman.alsa-project.org/mailman/listinfo/alsa-devel



[Index of Archives]     [ALSA User]     [Linux Audio Users]     [Kernel Archive]     [Asterisk PBX]     [Photo Sharing]     [Linux Sound]     [Video 4 Linux]     [Gimp]     [Yosemite News]

  Powered by Linux