On Sat, Jun 17, 2017 at 10:09:34PM +0800, Shawn Guo wrote: > + /* Mute control */ > + SOC_DOUBLE("Playback Master Mute", AUD96P22_MUTE_2, 0, 1, 1, 0), > + SOC_DOUBLE("Headset Mute", AUD96P22_MUTE_2, 4, 5, 1, 0), As covered in ControlNames.txt mute and other on/off controls should be named ending in Switch so UIs know what to do with them. > +static int aud96p22_startup(struct snd_pcm_substream *substream, > + struct snd_soc_dai *dai) > +{ > + struct aud96p22_priv *priv = snd_soc_codec_get_drvdata(dai->codec); > + struct regmap *regmap = priv->regmap; > + > + /* Overall power-up */ > + regmap_update_bits(regmap, AUD96P22_PD_0, PD_0_PDZ, PD_0_PDZ); Why is this not done with DAPM? > + /* Reset ADC and DAC path */ > + regmap_write(regmap, AUD96P22_RESET, 0x0); > + regmap_write(regmap, AUD96P22_RESET, 0x3); What does this mean?
Attachment:
signature.asc
Description: PGP signature
_______________________________________________ Alsa-devel mailing list Alsa-devel@xxxxxxxxxxxxxxxx http://mailman.alsa-project.org/mailman/listinfo/alsa-devel