On Wed, Apr 19, 2017 at 07:04:20PM +0200, Arnd Bergmann wrote: > The new PLL configuration code triggers a harmless warning: > > sound/soc/codecs/wm8960.c: In function 'wm8960_configure_clocking': > sound/soc/codecs/wm8960.c:735:3: error: 'best_freq_out' may be used uninitialized in this function [-Werror=maybe-uninitialized] > wm8960_set_pll(codec, freq_in, best_freq_out); > ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ > sound/soc/codecs/wm8960.c:699:12: note: 'best_freq_out' was declared here > > I think the warning was introduced by Daniel's bugfix. I've come up > with a way to simplify the code in a way that is more readable to > both humans and to gcc, which gets us rid of the warning. > > Fixes: 84fdc00d519f ("ASoC: codec: wm9860: Refactor PLL out freq search") > Fixes: 303e8954af8d ("ASoC: codec: wm8960: Stop when a matching PLL freq is found") > Signed-off-by: Arnd Bergmann <arnd@xxxxxxxx> > --- Acked-by: Charles Keepax <ckeepax@xxxxxxxxxxxxxxxxxxxxxxxxxxx> Thanks, Charles _______________________________________________ Alsa-devel mailing list Alsa-devel@xxxxxxxxxxxxxxxx http://mailman.alsa-project.org/mailman/listinfo/alsa-devel