On Thu, Mar 16, 2017 at 10:09 PM Mark Brown <broonie@xxxxxxxxxx> wrote: > On Thu, Mar 16, 2017 at 04:39:51PM +0800, Kai-Heng Feng wrote: > > > + switch (event) { > > + case SND_SOC_DAPM_PRE_PMD: > > + case SND_SOC_DAPM_POST_PMD: > > + case SND_SOC_DAPM_POST_PMU: > > + snd_soc_write(codec, RT286_SET_AMP_GAIN_HPO, AMP_OUT_MUTE); > > + break; > > + case SND_SOC_DAPM_PRE_PMU: > > + snd_soc_write(codec, RT286_SET_AMP_GAIN_HPO, > AMP_OUT_UNMUTE); > > + break; > > After power up we mute the amplifier? That's worthy of a comment... > > > + rt286->is_dell_dino = dmi_check_system(dmi_dell_dino) ? true : > false; > > + > > Just directly assign the boolean value, the ternery operator is just > making thins harder to read here. > Should I make the int implicitly convert to bool or use '!!' operator? _______________________________________________ Alsa-devel mailing list Alsa-devel@xxxxxxxxxxxxxxxx http://mailman.alsa-project.org/mailman/listinfo/alsa-devel