On Tue, Apr 19, 2016 at 11:55:52AM +0530, Vinod Koul wrote: > On Tue, Apr 12, 2016 at 11:32:07AM +0100, Charles Keepax wrote: > > > + * @state: state to transition the stream to > > + * > > + * Stop the stream and set its state. > > + * > > + * Should be called with compressed device lock held. > > + */ > > +int snd_compr_stop_error(struct snd_compr_stream *stream, > > + snd_pcm_state_t state) > > Do we want the state as an agument here, since we are invoking stop, it > should transistion to the stopped state > This was my interpretation of this comment of yours: "Also should this be made a generic stop rather than xrun. Perhaps the reason can be specified as an argument." If you clarify what you are looking for I am happy to respin. We should set the state to something that indicates there has been an error, such that things are distinct from a normal stop operation. Personally I liked simply calling the function snd_compr_stop_xrun and always setting it to xrun and it matches what the PCM framework does. So I am happy to go back to that if you prefer? Thanks, Charles _______________________________________________ Alsa-devel mailing list Alsa-devel@xxxxxxxxxxxxxxxx http://mailman.alsa-project.org/mailman/listinfo/alsa-devel