On Thu, Oct 09, 2008 at 08:58:08AM +0200, John Kacur wrote: > On Thu, Sep 4, 2008 at 4:43 PM, Mark Brown > <broonie@xxxxxxxxxxxxxxxxxxxxxxxxxxx> wrote: > code, and IMO make it more readable, something like this? > + switch (fmt & SND_SOC_DAIFMT_MASTER_MASK) { > + case SND_SOC_DAIFMT_CBM_CFM: /* Passing Case */ > + break; > + case SND_SOC_DAIFMT_CBS_CFS: /* Failing Cases */ > + case SND_SOC_DAIFMT_CBM_CFS: > + case SND_SOC_DAIFMT_CBS_CFM: > + ret = -EINVAL; > + break; > + default: > + printk(KERN_INFO "Unknown SND_SOC_DAIFMT kind\n"); > + ret = -EINVAL; > + break; > + } Yes, that's better - I'd remove the comments (they don't add much) and the prinkt() should be a KERN_ERR or higher severity since this should only happen as a result of a buggy machine driver. You could also just have a single default: for the unsupported types. _______________________________________________ Alsa-devel mailing list Alsa-devel@xxxxxxxxxxxxxxxx http://mailman.alsa-project.org/mailman/listinfo/alsa-devel