On Fri, 11 Aug 2023 18:48:37 +0200, Cezary Rojewski wrote: > > --- a/sound/core/pcm_lib.c > +++ b/sound/core/pcm_lib.c > @@ -1706,6 +1706,36 @@ int snd_pcm_hw_param_last(struct snd_pcm_substream *pcm, > } > EXPORT_SYMBOL(snd_pcm_hw_param_last); > > +/** > + * params_bps - Get the number of bits per the sample. > + * @p: hardware parameters > + * > + * Return: The number of bits per sample based on the format, > + * subformat and msbits the specified hw params has. > + */ > +int params_bps(const struct snd_pcm_hw_params *p) It's a too generic name. Please put the suffix like snd_xxx_. There are a few params_xxx() in the current tree, but those are rather macros, and left so just for laziness to convert every piece. You don't need to follow that pattern. thanks, Takashi