On Wed, 05 Apr 2023 22:12:20 +0200, Oswald Buddenhagen wrote: > @@ -2262,7 +2156,7 @@ Typical code would be like the following. > /* over the period boundary? */ > if (chip->size >= runtime->period_size) { > /* reset the accumulator */ > - chip->size %= runtime->period_size; > + chip->size -= runtime->period_size; > /* call updater */ > spin_unlock(&chip->lock); > snd_pcm_period_elapsed(substream); Hmm, this kind of change shouldn't be sneaked in. That's more than the typo fixes etc, and even worse, it's a wrong replacement. thanks, Takashi