On Tue, Jun 14, 2022 at 09:55:41AM -0500, Pierre-Louis Bossart wrote: > > >> @@ -809,6 +814,10 @@ void hda_set_dai_drv_ops(struct snd_sof_dev *sdev, struct snd_sof_dsp_ops *ops) > >> if (!hda_use_tplg_nhlt) > >> ipc4_data->nhlt = intel_nhlt_init(sdev->dev); > >> > >> +#if IS_ENABLED(CONFIG_SND_SOC_SOF_INTEL_SOUNDWIRE) > >> + sdw_callback.trigger = ipc4_be_dai_common_trigger; > >> +#endif > > > > #if should not be in .c files if at all possible. Surely there's a > > better way here... > > we could use > > if (IS_ENABLED(CONFIG_SND_SOC_SOF_INTEL_SOUNDWIRE)) > sdw_callback.trigger = ipc4_be_dai_common_trigger; > > would that work? It's more readable, right? Also easier to maintain over time. > We try to keep this driver configurable, not all platforms require > SoundWire or HDaudio, and that 'sdw_callback' ops structure is > conditionally declared. Perhaps don't conditionally declare that? How much does it really save to do that? thanks, greg k-h