Dne 04. 04. 21 v 8:59 Takashi Sakamoto napsal(a): > GCC warns that snd_ctl_led_get() uses stack frame over 1024 bytes. > > control_led.c: In function ‘snd_ctl_led_get’: > control_led.c:128:1: warning: the frame size of 1504 bytes is larger than 1024 bytes [-Wframe-larger-than=] > > When taking care of convension in Linux kernel development. it's preferable > to suppress too large usage of kernel stack, when the function call is not > in critical part. > > This commit fixes the bug, including some minor code refactoring relevant > to variable names. > > Fixes: 22d8de62f11b ("ALSA: control - add generic LED trigger module as the new control layer") > Signed-off-by: Takashi Sakamoto <o-takashi@xxxxxxxxxxxxx> > --- > sound/core/control_led.c | 68 ++++++++++++++++++++++++++-------------- > 1 file changed, 44 insertions(+), 24 deletions(-) > > diff --git a/sound/core/control_led.c b/sound/core/control_led.c > index b97f118cd54e..1be854a861f0 100644 > --- a/sound/core/control_led.c > +++ b/sound/core/control_led.c > @@ -94,34 +94,35 @@ static struct snd_ctl_led *snd_ctl_led_get_by_access(unsigned int access) > return &snd_ctl_leds[group]; > } > > -static int snd_ctl_led_get(struct snd_ctl_led_ctl *lctl) > +static int snd_ctl_led_get(struct snd_ctl_led_ctl *lctl, struct snd_ctl_elem_info *elem_info, > + struct snd_ctl_elem_value *elem_value) I think info, value should be enough as names for the arguments here. It increases readability. Jaroslav -- Jaroslav Kysela <perex@xxxxxxxx> Linux Sound Maintainer; ALSA Project; Red Hat, Inc.