On Tue, Mar 23, 2021 at 08:14:43PM +0800, caizhichao wrote: > From: Zhichao Cai <caizhichao@xxxxxxxxxx> > > Simplify the return expression. > > Signed-off-by: Zhichao Cai <caizhichao@xxxxxxxxxx> > --- > sound/i2c/i2c.c | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > > diff --git a/sound/i2c/i2c.c b/sound/i2c/i2c.c > index 847e3b6..dfcc87e 100644 > --- a/sound/i2c/i2c.c > +++ b/sound/i2c/i2c.c > @@ -235,9 +235,7 @@ static int snd_i2c_bit_sendbyte(struct snd_i2c_bus *bus, unsigned char data) > for (i = 7; i >= 0; i--) > snd_i2c_bit_send(bus, !!(data & (1 << i))); > err = snd_i2c_bit_ack(bus); > - if (err < 0) > - return err; > - return 0; > + return err < 0 ? err : 0; This isn't a simplification, you're just making the code harder to read for no good reason. > } > > static int snd_i2c_bit_readbyte(struct snd_i2c_bus *bus, int last) Johan