struct qcom_swrm_port_config {
u8 si;
u8 off1;
u8 off2;
u8 bp_mode;
+ u8 hstart;
+ u8 hstop;
+ u8 word_length;
+ u8 bgp_count;
I couldn't figure out what 'bgp' was and had to search. Not sure how
you came up with this abbreviation of "qcom,ports-block-group-count".
Adding a comment wouldn't hurt.
I will rename this to blk_group_count which makes more sense!
sounds good.
+ u8 lane_control;
Are you able to use lane_control != 0 ? I thought we were missing
stuff at the bus.c level?
Am not sure what is missing in bus.c but we do use lane_control for RX
slave on WCD938x codec. This uses datalane 1 for HPH and lane0 for
Compander/Class-H and other ports.
And it works!
Ah, good to know, thanks for the pointer.