On Mon, 21 Jan 2008, Takashi Iwai wrote: > At 18 Jan 2008 21:13:36 +0100, > Robert Jarzmik wrote: > > > > diff --git a/sound/soc/soc-dapm.c b/sound/soc/soc-dapm.c > > index ea20138..f22a1bb 100644 > > --- a/sound/soc/soc-dapm.c > > +++ b/sound/soc/soc-dapm.c > > @@ -281,7 +281,7 @@ static int dapm_new_mixer(struct snd_soc_codec *codec, > > struct snd_soc_dapm_widget *w) > > { > > int i, ret = 0; > > - char name[32]; > > + char name[44]; > > Let's add a global const in asound.h instead of using a magic number > everywhere. What about this: int namelen = sizeof(w->kcontrols[0].name); Jaroslav ----- Jaroslav Kysela <perex@xxxxxxxx> Linux Kernel Sound Maintainer ALSA Project, Red Hat, Inc. _______________________________________________ Alsa-devel mailing list Alsa-devel@xxxxxxxxxxxxxxxx http://mailman.alsa-project.org/mailman/listinfo/alsa-devel