On Tue, 04 Feb 2020 11:27:46 +0100, Nikhil Mahale wrote: > > If dyn_pcm_assign is set, different jack objects are being created > for pcm and pins. > > If dyn_pcm_assign is set, generic_hdmi_build_jack() calls into > add_hdmi_jack_kctl() to create and track separate jack object for > pcm. Like sync_eld_via_acomp(), hdmi_present_sense_via_verbs() also > need to report status change of the pcm jack. > > Rename pin_idx_to_jack() to pin_idx_to_pcm_jack(). Update > hdmi_present_sense_via_verbs() to report plug state of pcm jack > object. Unlike sync_eld_via_acomp(), for !acomp drivers the pcm > jack's plug state must be consistent with plug state > of pin's jack. Thanks, the new patch looks better. > Fixes: 5398e94fb753 ("ALSA: hda - Add DP-MST support for NVIDIA codecs") > Signed-off-by: Nikhil Mahale <nmahale@xxxxxxxxxx> We need Cc to stable here. I'll add it when applying. Also, it deserves Reported-by from Martin. Martin, could you retest with this patch? I'll queue the patch once after confirmation. Just one minor nitpick: > + if (spec->dyn_pcm_assign && pcm_jack && !do_repoll) { > + int state = 0; > + > + if (!!(jack->pin_sense & AC_PINSENSE_PRESENCE)) > + state = SND_JACK_AVOUT; The "!!" is superfluous. I'll drop it. Takashi _______________________________________________ Alsa-devel mailing list Alsa-devel@xxxxxxxxxxxxxxxx https://mailman.alsa-project.org/mailman/listinfo/alsa-devel