> > > > diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c > index 0bd2cb2..8e49fb8 100644 > --- a/sound/soc/soc-core.c > +++ b/sound/soc/soc-core.c > @@ -261,34 +261,18 @@ static inline void snd_soc_debugfs_exit(void) > static int snd_soc_rtdcom_add(struct snd_soc_pcm_runtime *rtd, > struct snd_soc_component *component) > Morimoto-san, Thanks for this change. This is a lot more intuitive. But may I suggest that we should also possibly consider changing the function name above? How about snd_soc_rtd_add_component() maybe? Thanks, Ranjani > { > - struct snd_soc_rtdcom_list *rtdcom; > struct snd_soc_component *comp; > + int i; > > - for_each_rtd_components(rtd, rtdcom, comp) { > + for_each_rtd_components(rtd, i, comp) { > /* already connected */ > if (comp == component) > return 0; > } > _______________________________________________ Alsa-devel mailing list Alsa-devel@xxxxxxxxxxxxxxxx https://mailman.alsa-project.org/mailman/listinfo/alsa-devel