Hi Mark, On Tue, 2019-11-12 at 17:34 +0000, Mark Brown wrote: > On Tue, Nov 12, 2019 at 12:22:18PM +0800, Eason Yen wrote: ... > > It'd be better to split these two into separate patches, they're two > separate things. Ideally the refactoring should just be simple code > motion. Right now the patch is a bit difficult to follow. > Ok, I will separate this patch soon. > > static int mtk_regmap_update_bits(struct regmap *map, int reg, > > - unsigned int mask, > > - unsigned int val, int shift) > > + unsigned int mask, > > + unsigned int val, int shift) > > { > > if (reg < 0 || WARN_ON_ONCE(shift < 0)) > > return 0; > > This is an unrelated indentation change? Yes, it is an alignment that to match open parenthesis. > > > + dev_info(afe->dev, "%s(), %s, ch %d, rate %d, fmt %d, dma_addr %pad, dma_area %p, dma_bytes 0x%zx\n", > > + __func__, memif->data->name, > > + channels, rate, format, > > + &substream->runtime->dma_addr, > > + substream->runtime->dma_area, > > + substream->runtime->dma_bytes); > > This is going to get noisy, dev_dbg at most please. Ok, thanks for your suggestion. Regards, Eason _______________________________________________ Alsa-devel mailing list Alsa-devel@xxxxxxxxxxxxxxxx https://mailman.alsa-project.org/mailman/listinfo/alsa-devel