On 2022/07/04 14:25, Hari Bathini wrote: > This patch series fixes a couple of issues with bt on ppc64 and also > does some code cleanup. > > Patch #1 fixes the broken '-S' option on ppc64. The next patch changes > h/w interrupt stack allocation to dynamic as this field remains unused > in most cases. The next patch renames ppc64_paca_init() function to > ppc64_paca_percpu_offset_init() to reflect what the function actually > does. Patch#4 adds support to process backtrace when the stack pointer > is in an emergency SP. The next patch adds support to print emergency > stack data. And the last patch ensures a variable is used instead of > machdep->machspec to optimize code and improve readability. > > Changes in v2: > * Print "(unused)", if hwintrstack is not being used. > * Avoid using variable length array for paca_ptrs. > * With 'mach' command, print emergency stack data by default > (no special option). Thank you for the v2. There are a few typos but no need to respin so for the series: Acked-by: Kazuhito Hagio <k-hagio-ab@xxxxxxx> They are nice improvements! Thanks, Kazu > > > Hari Bathini (6): > ppc64: fix bt for '-S' case > ppc64: dynamically allocate h/w interrupt stack > ppc64: rename ppc64_paca_init to ppc64_paca_percpu_offset_init > ppc64: handle backtrace when CPU is in an emerency stack > ppc64: print emergency stacks info with 'mach' command > ppc64: use a variable for machdep->machspec > > defs.h | 14 +- > ppc64.c | 535 ++++++++++++++++++++++++++++++++++++++++---------------- > 2 files changed, 393 insertions(+), 156 deletions(-) > -- Crash-utility mailing list Crash-utility@xxxxxxxxxx https://listman.redhat.com/mailman/listinfo/crash-utility Contribution Guidelines: https://github.com/crash-utility/crash/wiki