On 2025-02-27 6:11 AM, Oder Chiou wrote:
-----Original Message-----
From: Cezary Rojewski <cezary.rojewski@xxxxxxxxx>
Sent: Wednesday, February 26, 2025 5:42 PM
To: Oder Chiou <oder_chiou@xxxxxxxxxxx>; broonie@xxxxxxxxxx
Cc: tiwai@xxxxxxxx; perex@xxxxxxxx; amadeuszx.slawinski@xxxxxxxxxxxxxxx;
linux-sound@xxxxxxxxxxxxxxx; Flove(HsinFu) <flove@xxxxxxxxxxx>;
andriy.shevchenko@xxxxxxxxxxxxxxx; Shuming [范書銘]
<shumingf@xxxxxxxxxxx>; Jack Yu <jack.yu@xxxxxxxxxxx>; Derek [方德義]
<derek.fang@xxxxxxxxxxx>
Subject: Re: [PATCH 20/24] ASoC: codecs: rt1015p: Update definition of
device_id tables
...
diff --git a/sound/soc/codecs/rt1015p.c b/sound/soc/codecs/rt1015p.c
index 44e7fe3c32da..33917438196f 100644
--- a/sound/soc/codecs/rt1015p.c
+++ b/sound/soc/codecs/rt1015p.c
@@ -133,9 +133,11 @@ MODULE_DEVICE_TABLE(of, rt1015p_device_id);
#ifdef CONFIG_ACPI
static const struct acpi_device_id rt1015p_acpi_match[] = {
- { "RTL1015", 0},
- { "RTL1019", 0},
- { },
+ { "RTL1015" },
+ { "RTL1019" },
+ { "10EC1015" },
+ { "10EC1019" },
+ {}
There are different settings for RTL1015, RTL1019, 10EC1015, and 10EC1019.
RTL1015 and RTL1019 are used for powering up and down via the GPIO.
10EC1015 and 10EC1019 are used for the I2C-controlled driver.
Therefore 10EC1015 and 10EC1019 should be removed.
Sorry for the delay in response and thank for you the feedback.
I'm surprised this hasn't come up earlier in the discussion. I'll
probably cut off problematic patches so that majority can be merged.
It's important to have some follow up though, on the subject you
mentioned. Correct me if I'm wrong but from the .c files it seems:
for DT/ARM rt1015 & rt1015p are represented by:
.compatible = "realtek,rt1015"
.compatible = "realtek,rt1015p"
for ACPI/x86 rt1015 & rt1015p are represented by:
"10EC1015"
"RTL1015"
The first pair is nice and clean, the second is confusing and error
prone. Do you know where the second pair originated from?
10EC is defined by the PCI domain, and RTL is defined by the PNP domain.
To distinguish these, 1015, 1019, and 5682 use different drivers,
with the RTL prefix being used to instead of the p postfix in the DT.
Thank you for the reminder. I'm aware of the origins for PCI/PNP
prefixes, though. In fact, there is more to it - OBDA [1] and ALG [2].
The idea is to choose one _recommended path_ and follow it. If the
desire is to name future chips using suffixes such as -p or -s, then
perhaps PNP-based naming should have been selected instead. Another
option would be to change the hardware naming scheme e.g: '1016' instead
of '1015p'.
If the latter is not an option, why not:
RTL1015
RTL1015P
on ACPI/x86 side? Aligns with ARM equivalent nicely, no?
[1]: https://uefi.org/ACPI_ID_List?acpi_search=realtek
[2]: https://uefi.org/PNP_ID_List?pnp_search=realtek
Kind regards,
Czarek
[Index of Archives]
[Pulseaudio]
[Linux Audio Users]
[ALSA Devel]
[Fedora Desktop]
[Fedora SELinux]
[Big List of Linux Books]
[Yosemite News]
[KDE Users]