On Tue, Oct 15 2024 at 20:51, Philipp Stanner wrote:
> +/**
> + * pci_intx - enables/disables PCI INTx for device dev, unmanaged version
mismatch vs. actual function name.
> + * @pdev: the PCI device to operate on
> + * @enable: boolean: whether to enable or disable PCI INTx
> + *
> + * Enables/disables PCI INTx for device @pdev
> + *
> + * This function behavios identically to pci_intx(), but is never managed with
> + * devres.
> + */
> +void pci_intx_unmanaged(struct pci_dev *pdev, int enable)
This is a misnomer. The function controls the INTX_DISABLE bit of a
PCI device. Something like this:
void __pci_intx_control()
{
}
static inline void pci_intx_enable(d)
{
__pci_intx_control(d, true);
}
.....
makes it entirely clear what this is about.
Hmm?
Thanks,
tglx
[Index of Archives]
[Pulseaudio]
[Linux Audio Users]
[ALSA Devel]
[Fedora Desktop]
[Fedora SELinux]
[Big List of Linux Books]
[Yosemite News]
[KDE Users]