On 10:07 Tue 16 Oct , Nicolas Ferre wrote: > On 10/16/2012 05:56 AM, Bo Shen : > > This patch removes some code duplication by using module_platform_driver > > > > Signed-off-by: Bo Shen <voice.shen@xxxxxxxxx> > > Very good simplification but... > > > --- > > drivers/misc/atmel-ssc.c | 18 ++++-------------- > > 1 file changed, 4 insertions(+), 14 deletions(-) > > > > diff --git a/drivers/misc/atmel-ssc.c b/drivers/misc/atmel-ssc.c > > index 23dcb76..ac00f83 100644 > > --- a/drivers/misc/atmel-ssc.c > > +++ b/drivers/misc/atmel-ssc.c > > @@ -68,7 +68,7 @@ void ssc_free(struct ssc_device *ssc) > > } > > EXPORT_SYMBOL(ssc_free); > > > > -static int __init ssc_probe(struct platform_device *pdev) > > +static int ssc_probe(struct platform_device *pdev) > > Here you remove the __init altogether, maybe converting to __devinit is > the proper replacement for this? I do not know myself but if anybody knows? yes __devinit is mandatory Best Regards, J. -- To unsubscribe from this list: send the line "unsubscribe linux-sound" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html
- Follow-Ups:
- Re: [PATCH 2/2] ASoC: atmel-ssc: use module_platform_driver macro
- From: Russell King - ARM Linux
- Re: [PATCH 2/2] ASoC: atmel-ssc: use module_platform_driver macro
- From: Bo Shen
- Re: [PATCH 2/2] ASoC: atmel-ssc: use module_platform_driver macro
- References:
- [PATCH 1/2] ASoC: atmel-ssc: use devm_xxx() managed function
- From: Bo Shen
- [PATCH 2/2] ASoC: atmel-ssc: use module_platform_driver macro
- From: Bo Shen
- Re: [PATCH 2/2] ASoC: atmel-ssc: use module_platform_driver macro
- From: Nicolas Ferre
- [PATCH 1/2] ASoC: atmel-ssc: use devm_xxx() managed function
- Prev by Date: Re: [PATCH 2/2] ASoC: atmel-ssc: use module_platform_driver macro
- Next by Date: Re: [PATCH 2/2] ASoC: atmel-ssc: use module_platform_driver macro
- Previous by thread: Re: [PATCH 2/2] ASoC: atmel-ssc: use module_platform_driver macro
- Next by thread: Re: [PATCH 2/2] ASoC: atmel-ssc: use module_platform_driver macro
- Index(es):
![]() |