Re: Windows Guest on KVM running "single core" after windows update

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 5/9/23 9:59 AM, Marc wrote:
I have a Windows 10 pro (64bit) long time running as a libvirt/KVM guest
that I think Windows Update finally narfed.

The hardware is a supermicro motherboard with dual Intel E5-2640 CPUs
for a total of 40 threads and 64GB

The guest is allocated 2sockets, 5cores, 2 threads and 32GB of RAM.
(I've also tried 1 socket, 20 cores, 1 thread and 1s10c2t -- no help)

In an SSH session to the linux host (CentOS7 - up to date), htop shows 1
core pegged and abnormal distribution of load (like it used to) even
with fun little tools in Windows like the PowerToy -> CPUStress64.exe

(i.e. the head CPU will show 90-99% and next thread in HTOP will show
like 10% which then trails off to like 5%)

Even if I tell CPUStress64.exe to load up 10 or 15 threads worth of

I think the processor type and configuration options are most important. I am also having win10 on el7 and weird idle load of 35%. This win10 is also constantly writing to disk. Best is to disable al diagnostics services you do not use. I also noticed that el9 is smoother with win10 guests, I copied the same guest and there it is around 14%*. But if any one has an advice to get this to levels of a linux guest doing nothing, I am very anxious to hear about it.

*not exactly same processors.

Thanks for the reply.

Yea -- this isn't a new VM. It's been running fine for years. I did a fresh install of Win10 around 2018 because of previous issues more of boot stability. But the system has been running fine since then. It's only this recent Windows update that has clobbered itself.

And honestly, I'm not surprised. Windows can barely run reliably on bare-metel let alone a VM install.

I've tried playing with the CPU topology and nothing seems to help.

I will say one thing that I noticed is: when giving the guest 8 cores and not setting the topology, windows device manager shows 8 CPUs but the task manager only shows 2. Feh. Windows.

Anyway - looks like a fresh install to 22H2 is in my future. Oh well.

I have backups of needed data of the 2 applications the VM is used for. And the data (like video footage) is off on a couple of raw partitions. So the QCOW2 image could honestly get nuked at any time and I don't really lose anything important. Just the time to do a fresh re-install of Windows and install the applications again.

I just wondered if anyone else saw similar behavior.

Thanks again,


[Index of Archives]     [Virt Tools]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [KDE Users]

  Powered by Linux