Libvirt virsh : Error starting network, cannot execute binary /usr/sbin/iptables

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]



I am a bit lost and hope someone can help me. I am running Debian bookworm (testing) with last updates.

$ sudo apt policy libvirt-daemon
  Installé : 8.5.0-1
  Candidat : 8.5.0-1
 Table de version :
 *** 8.5.0-1 100
        100 /var/lib/dpkg/status

I am unable to start default network , and get an error related to iptables :

$ sudo virsh net-start default
erreur :Impossible de démarrer le réseau default
erreur :internal error: Failed to apply firewall rules /usr/sbin/iptables -w --table filter --list-rules: libvirt:  erreur : cannot execute binary /usr/sbin/iptables: Aucun fichier ou dossier de ce type

Sorry for the french, it says "impossible to start default network" and "no such file or folder" at the end.

It is true I removed iptables because I want to use only nftables (I removed both ufw and iptables packages (apt remove), and enabled the nftables service before error raises). Before this, all was fine, but when I enabled nftables, all VMs disapeared  from virt-manager).

I uninstalled KVM related packages and reinstalled, still the same.

I also installed back iptables, but strangely I still get the same error, although binary /usr/sbin/iptables is there.

I tried many things with no luck, restarted libvirtd service, recreated the network, etc...

Has anyone some idea about what is happening here ? is there some incompatibility with nftables (firewalld service is disabled) and libvirt ?

Thank you,

[Index of Archives]     [Virt Tools]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [KDE Users]

  Powered by Linux