Re: Can RHEL7 VM run remote commands to Fedora36 host?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Well I don't know if this helps, but it's there a reason you haven't tried running the command that succeeds on the laptop directly over SSH? 

ssh LAPTOPUSER@Laptop "virsh --connect qemu:///system start beaker-test-vm1.beaker"

Ben S

On Thu, Jul 28, 2022, 11:16 AM Carol Bouchard <cbouchar@xxxxxxxxxx> wrote:
I have a Fedora36 laptop which hosts VMs with RHEL7 using libvirt.  One of
the RHEL7 VMs, runs remote commands (as root) to 'start' another VM by
way of my laptop.  In other words,  the following command is run:
virsh --connect 'qemu+ssh://' start beaker-test-vm1.beaker
If I run non-remote version of the command on the laptop, it is successful. For example,
virsh --connect qemu:///system start beaker-test-vm1.beaker  <-- Successful on laptop.

If I do a query like the following (notice socket use), it is successful.
virsh -d0 --connect 'qemu+ssh://' domstate beaker-test-vm1.beaker

Without socket, I get the following error:

error: failed to connect to the hypervisor

error: End of file while reading data: Ncat: No such file or directory.: Input/output error

This does not work for 'start' because I believe this is a read-only socket since I see the error:
error: Failed to start domain beaker-test-vm1.beaker
error: operation forbidden: read only access prevents virDomainCreate

When I look at my laptop, there is no /var/run/libvirt/libvirt-sock.  So.....I've been wondering
whether RHEL7 virsh/libvirt is compatible with Fedora36.  Is there a work-around?  I can't
change the distros on my laptop or VMs.


[Index of Archives]     [Virt Tools]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [KDE Users]

  Powered by Linux