Rename them to comply with the naming policy. --- src/libvirt_private.syms | 2 +- src/qemu/qemu_domain.c | 2 +- src/qemu/qemu_driver.c | 2 +- src/util/virstoragefile.c | 6 +++--- src/util/virstoragefile.h | 2 +- 5 files changed, 7 insertions(+), 7 deletions(-) diff --git a/src/libvirt_private.syms b/src/libvirt_private.syms index a793b4c..b3f73f9 100644 --- a/src/libvirt_private.syms +++ b/src/libvirt_private.syms @@ -1904,8 +1904,8 @@ virStorageNetHostTransportTypeFromString; virStorageNetHostTransportTypeToString; virStorageNetProtocolTypeToString; virStorageSourceAuthClear; +virStorageSourceBackingStoreClear; virStorageSourceClear; -virStorageSourceClearBackingStore; virStorageSourceFree; virStorageSourceGetActualType; virStorageSourceGetSecurityLabelDef; diff --git a/src/qemu/qemu_domain.c b/src/qemu/qemu_domain.c index 2e55c99..f3f42be 100644 --- a/src/qemu/qemu_domain.c +++ b/src/qemu/qemu_domain.c @@ -2437,7 +2437,7 @@ qemuDomainDetermineDiskChain(virQEMUDriverPtr driver, if (disk->src->backingStore) { if (force) - virStorageSourceClearBackingStore(disk->src); + virStorageSourceBackingStoreClear(disk->src); else goto cleanup; } diff --git a/src/qemu/qemu_driver.c b/src/qemu/qemu_driver.c index 22699c1..41d7bb6 100644 --- a/src/qemu/qemu_driver.c +++ b/src/qemu/qemu_driver.c @@ -12868,7 +12868,7 @@ qemuDomainSnapshotCreateSingleDiskActive(virQEMUDriverPtr driver, * recompute it. Better would be storing the chain ourselves rather than * reprobing, but this requires modifying domain_conf and our XML to fully * track the chain across libvirtd restarts. */ - virStorageSourceClearBackingStore(disk->src); + virStorageSourceBackingStoreClear(disk->src); if (virStorageFileInit(snap->src) < 0) goto cleanup; diff --git a/src/util/virstoragefile.c b/src/util/virstoragefile.c index 6a57327..0c50de1 100644 --- a/src/util/virstoragefile.c +++ b/src/util/virstoragefile.c @@ -1551,14 +1551,14 @@ virStorageSourceGetActualType(virStorageSourcePtr def) /** - * virStorageSourceClearBackingStore: + * virStorageSourceBackingStoreClear: * * @src: disk source to clear * * Clears information about backing store of the current storage file. */ void -virStorageSourceClearBackingStore(virStorageSourcePtr def) +virStorageSourceBackingStoreClear(virStorageSourcePtr def) { if (!def) return; @@ -1599,7 +1599,7 @@ virStorageSourceClear(virStorageSourcePtr def) virStorageNetHostDefFree(def->nhosts, def->hosts); virStorageSourceAuthClear(def); - virStorageSourceClearBackingStore(def); + virStorageSourceBackingStoreClear(def); } diff --git a/src/util/virstoragefile.h b/src/util/virstoragefile.h index f98a763..48c7e02 100644 --- a/src/util/virstoragefile.h +++ b/src/util/virstoragefile.h @@ -321,7 +321,7 @@ void virStorageSourcePoolDefFree(virStorageSourcePoolDefPtr def); void virStorageSourceClear(virStorageSourcePtr def); int virStorageSourceGetActualType(virStorageSourcePtr def); void virStorageSourceFree(virStorageSourcePtr def); -void virStorageSourceClearBackingStore(virStorageSourcePtr def); +void virStorageSourceBackingStoreClear(virStorageSourcePtr def); virStorageSourcePtr virStorageSourceNewFromBacking(virStorageSourcePtr parent); typedef int -- 1.9.3 -- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list