On 05/23/14 18:38, Eric Blake wrote: > On 05/22/2014 07:47 AM, Peter Krempa wrote: >> My future work will modify the metadata crawler function to use the >> storage driver file APIs to access the files instead of accessing them >> directly so that we will be able to request the metadata for remote >> files too. To avoid linking the storage driver to every helper file >> using the utils code, the backing chain traversal function needs to be >> moved to the storage driver source. >> >> Additionally the virt-aa-helper and virstoragetest programs need to be >> linked with the storage driver as a result of this change. >> --- >> cfg.mk | 2 +- >> src/Makefile.am | 2 + >> src/libvirt_private.syms | 2 +- >> src/qemu/qemu_domain.c | 2 + >> src/security/virt-aa-helper.c | 2 + >> src/storage/storage_driver.c | 233 ++++++++++++++++++++++++++++++++++++++++++ >> src/storage/storage_driver.h | 5 + >> src/util/virstoragefile.c | 233 +----------------------------------------- >> src/util/virstoragefile.h | 7 +- >> tests/Makefile.am | 7 +- >> tests/virstoragetest.c | 2 + >> 11 files changed, 258 insertions(+), 239 deletions(-) >> >> >> /* Internal version that also supports a containing directory name. */ >> -static int >> +int >> virStorageFileGetMetadataFromFDInternal(virStorageSourcePtr meta, >> int fd, >> int *backingFormat) > > It's a bit confusing that we now have virStorageFile* functions spread > across two different files; maybe a later patch should rename the > storage_driver.h functions to have a different prefix? > We definitely can address this later. Any suggestions on the name of the moved code? Peter
Attachment:
signature.asc
Description: OpenPGP digital signature
-- libvir-list mailing list libvir-list@xxxxxxxxxx https://www.redhat.com/mailman/listinfo/libvir-list